
LEARNING PUNCH SOFTWARE (R):

MINI - TUTORIALS

BY PATRICIA GAMBURGO

Combining my architectural knowledge

with my Punch Software (R) experience

Copyright © 2013 Patricia Gamburgo
ISBN: 978-0-9919378-2-0



Punch! Software (R) is a registered trademark of Encore Software, Inc. Used under License.
The advice and opinions in this publication are solely those of the author who is not affiliated with Encore 

Software, Inc. in any manner.  Encore Software, Inc. has not reviewed or verified the content of this 
publication and does not endorse the information, advice or opinions contained herein.

Smashwords Edition, License Notes
This e-book is licensed for your personal enjoyment only. This e-book may not be re-sold or given away 
to other people. If you would like to share this book with another person, please purchase an additional 
copy for each recipient. If you are reading this book and did not purchase it, or it was not purchased for 

your use only, then please return to Smashwords.com and purchase your own copy. Thank you for 
respecting the hard work of this author.

ACKNOWLEDGEMENTS

_________________________________________________________________________

I’d like to thank to everyone that directly or indirectly helped me since I started this path with Punch! 
Software (R), but some people are really special.
Thank you to all the Punch! Software (R) users that took the time to send me emails and share with me 
what they needed, what they liked or didn’t like or didn’t understand and how they would like to learn the 
programs: I hope that these books will give you the answers that you are looking for.
For the readers of my first and second e-books Learning Punch Software (R): Importing, Exporting 
and Printing and Learning Punch Software (R): Basic & Advanced Training my deepest thank you 
for the feedback and the encouragement to publish more e-books.

Again, I’d like to thank to all the Punch! Software (R) team, specially PA, JS, and MH: you are great! 
And an enormous Thank You to Matt H. for the trust and patience. I am honored to serve as the Forum 
Moderator, Beta Tester as well as the author of these Punch! Software (R) e-books.

And, a very, very special and big thank you to JDK and MLK…. These e-books won’t exist without you!

Patricia Gamburgo
American Institute of Architects – International Associate

https://www.smashwords.com/books/view/343465
http://www.smashwords.com/books/view/298949
http://www.smashwords.com/books/view/298949


ABOUT THE MINI TUTORIALS

_________________________________________________________________________

I created the mini tutorials to help the users of the Punch Software (R) Forum in 2002. I published them 
through my website www.punchhelpers.com. 
These mini tutorials show the answers and solutions to issues experienced by Punch Software (R) users. 
Although they are still available (for free) in my website www.punchhelpers.com with free access, I 
noticed that they are in different formats and some images are outdated.
Also, the old mini tutorials show only the Windows versions.

For all these reasons, I decided to create this new e-book for the Learning Punch Software (R) series 
compiling and updating all the information as well as the addition of a collection of frequently asked 
questions, with answers.
For all the Punch Software (R) programs up to V17.5, Windows and Mac Versions.
These mini-tutorials show how to solve the issues. You will find step by step “how to use” tutorials and 
training in my additional e-books. I am working on two new titles for this series: “Power Tools” and 
“Landscape”

As always, my e-books combine my architectural knowledge with my Punch Software (R) experience.
I hope that you find it useful, and that you will enjoy reading this e-book as much as I enjoyed writing it!

Patricia Gamburgo
American Institute of Architects – International Associate

My website: www.punchhelpers.com 
My e-books series: Learning Punch Software (R) series
My e-books free video presentation: Pat’s e-books
My Facebook page: Punchhelpers at Facebook
Twitter: Follow me on Twitter
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ABOUT ME AND MY E-BOOKS



ISSUES IMPORTING 3D OBJECTS 

_________________________________________________________________________

The Punch Software (R) programs import 3D objects. Depending of the title and version, the programs 
import different formats. 
The importing processes are not complicated. However, in some cases, the objects’ formats and / or the 
morphology may complicate the importing process and the 3D rendering. 

As a general concept, there are 2 types of 3D objects:

The objects created within the program 
POB: a *.POB file is a Punch! Software (R) proprietary format for the objects developed with the 3D 
Workshop Power Tool.
CWP: a *. CWP file is a Punch! Software (R) proprietary format for the objects developed with the 3D 
Workshop Pro Power Tool.
These objects are imported without problems.

The objects created with other programs and imported in Punch
There are several formats that can be imported, such as 3DS or SKP, for example. Note that not all the 
programs / versions import all the formats.
Let’s examine this sphere. The image shows the object rendered, with light



The final rendering smoothens the surfaces, however, the fact is, that the object is composed by small 
pieces called “Polygons”
Objects with many polygons are larger (Mb) and it is not uncommon that they cause a rendering crash.

In the image below, we can see the polygons in the sphere without rendering and in wireframe mode

 Smaller polygons will create a smoother surface, but if the pieces are smaller, we will need 
more polygons to create the objects. As each polygon is an object, more polygons mean the necessity of 
more computer resources and more rendering time. Therefore, before you attempt to import a 3D 
object, try reducing the number of polygons

There are many programs (free and paid) that feature a polygons’ reduction tool. Usually, the programs 
have a 3D window and a panel to set the number of polygons. 

Question for this issue: Where can I find the polygon reduction programs?
Answer: In my Facebook page, you will find the names and websites for these programs

This is an example showing how the polygons’ reduction program works.
In the image below, we can see the original sphere and, at the right, the polygon counter: it shows 2666 
polygons (outlined in red)

https://www.facebook.com/punchhelpers.links


Let’s reduce the polygons to 2000



We can’t see any difference in the smoothing, but we reduced the polygons in 25%. Now, let’s reduce the 
polygons to 1500

As we can see, several areas of the sphere are distorted, therefore 1500 is not an acceptable value. You 
must balance the desired quality with the lower polygon value.

Question for this issue: Can I reduce the polygons of a POB object?
Answer: It is not necessary. The POBs are defined with different parameters and usually, they have a 
small size (Mb). If possible, I recommend the use of POBs 

 More Information and Tutorials about importing objects can be found in Patricia’s e-books

Learning Punch Software (R): Importing, Exporting and Printing

Learning Punch Software (R): Basic & Advanced Training
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ISSUES IMPORTING CAD FILES 

_________________________________________________________________________

The Punch Software (R) programs import DXF or DWG files. Each element (lines, surfaces, etc.) of these 
files can be converted to walls, decks, etc. Also, the DXF and DWG files are imported to create 2D 
symbols and details using the Section Detailer Power Tool and the Symbol Editor Power Tool.
However, many users cannot complete the importing process successfully. Why this problem happens? 

Pair of codes with values compose a DXF or DWG file. These values define the characteristics of the 
objects or entities. Depending on the files created, it will contain some pairs of codes or not. Therefore, a 
line is an entity (graphic object), with different attributes, but a border is an object (it is not graphic)
depending on these settings, in a file we’ll find 2D and 3D codes. Punch just imports 2D entities (2D 
files). 

Therefore, in order to import the file, you need to “clean” the file and configure the settings before you 
attempt to import the file. In order to clean the file, you will need a CAD program. There are many free 
versions, or you can use a demo version.

Question for this issue: Where can I find free CAD programs?
Answer: In my Facebook page, you will find the names and websites for these programs

These are the 7 most common issues found during this importing process (notice that all images are 
showing screenshots of different programs and versions, however, the issues are not exclusively from a 
certain program / version.)
Issue 1: I am trying to import a CAD file, the process seems complete, but all I get is a white screen.
Issue 2: When I try to import a CAD file, the program crashes.

Issue 3: When I try to import a CAD file, the program hangs and there is a “No responding” notification.
Issue 4: When I try to import a CAD file, I receive this error message

Issue 5: I am trying to import a CAD file, I am able to complete the process, but the plan is located out of 
the workspace

https://www.facebook.com/punchhelpers.links


Issue 6: I am trying to import a CAD file, I am able to complete the process, but the plan is bigger than 
the workspace
Issue 7: I am trying to import a CAD file, I am able to complete the process, but the plan has lots of 
points, lines and other artifacts

There isn’t a unique solution covering all the issues. Sometimes a step solves one issue, but 
another issue appears as you advance in the process. For this reason, I recommend to follow all the 
steps.
Keep in mind that Punch will use only the elements that can be converted to Intelligent Objects (walls, 
decks, etc.) so the remaining elements are superfluous.

General Settings
Verify the CAD version of the plan: in order to import a CAD file to Punch, the file must be DXF or 
DWG version 2004 or older. In my experience, version 2000 works better.
Verify your computer settings: check the language input of your computer (keyboard) => it must be 
United States or United States International.
External references: many CAD programs create drawing packages with linked documents. For this 
reason, the floor plans contain hyperlinks called External References. Delete all the external references.

Checking the plan contents
Floor plan: create a separate CAD file for each floor plan / level. CAD elevations and cross sections are 
useless in Punch, so exclude additional plans and elevations.
Superfluous elements: remove all the unnecessary elements like titles (outlined in red), hatches and 
symbols (blue arrow), title block and frame (brown arrow), fixtures  



Layers: make all the layers visible in order to look for hidden elements. If possible move all the elements 
to one layer.

Blocks and grouped elements: select all the CAD blocks and grouped elements. Unlink the elements 
using the Explode function (in CAD)

Trash: look for trash lines and elements and delete them. Notice that they can be hidden, so Zoom to Fit 
the screen in order to find these elements



Final cleaning: usually, the CAD programs have a cleaning feature called “Purge” or “Clean”. Use this 
tool in order to eliminate hidden junk

If your CAD floor plan includes several elements in the same drawing, like electricity, 
topography, etc. delete these elements in the plan that you intend to import. In this way, you will work 
faster in Punch. You can create additional CAD plans with the remaining elements (electricity, plumbing, 
etc.) and import them later.
Notice that CAD files are imported into Punch, therefore they will not Open using the Main menu.



 More Information and Tutorials about importing CAD files can be found in Patricia’s e-books

Learning Punch Software (R): Importing, Exporting and Printing

Learning Punch Software (R): Basic & Advanced Training

PRINTING FLOOR PLANS ISSUES 

_________________________________________________________________________

There are several options to print floor plans created with the Punch Software (R) programs. The choice 
depends of your goals and your printers or programs availability

Frequently Asked Questions about this issue:

Question 1: I have an old version and I’d like to print just a partial floor plan. How do I achieve this?
Answer 1: Punch Software (R) Versions 16 and older don't print partial plans => if you need to print just 
a room => create a JPG or BMP file and crop it. 

Question 2: I am trying to print a floor plan but I get several blank pages. Why is this happening?
Answer 2: keep in mind that Punch prints all the elements in the workspace, so if you have a small object 
in a remote corner (even a dot) the system will print all the empty workspace, and this will appear as 
blank pages.

Question 3: I am trying to print a floor plan showing the Electrical and Plumbing features, however the 
program prints just the floor plan. What am I doing wrong?
Answer 3: Windows Versions: If you are working / printing in the Floor tab, for example, you will see a 
small black arrow at the right of the name (old versions). By clicking on the small arrow or on the name 
of the tab (new versions) a drop down menu will open with the names of the tabs => you have the option 
of viewing or hiding other tabs. Just check the names of all the tabs you wish to show / print --> For 
example, if you are in the Floor tab => click on the name and select the Plumbing and Electrical tabs, so 
you'll see the Floor tab elements as well as the elements in the selected tab. 
Answer 3: Mac Versions: If you are working / printing in the Floor tab, go to the Main Menu => 2D => 
Plan Visibility => you have the option of viewing or hiding other tabs. Just check the names of all the tabs 
you wish to show / print --> For example, if you are in the Floor tab => click on the name and select the 
Plumbing and Electrical tabs, so you'll see the Floor tab elements as well as the elements in the selected 
tab. 

Question 4: How do I add a frame and a title block?
Answer 4: the frame can be created with the rectangle tool (Detail tab). The ready to use title blocks (in 3 
languages) are in the Templates library

https://www.smashwords.com/books/view/343465
http://www.smashwords.com/books/view/298949


Printing Options
Normal Printing: File => Print or Print to Scale => Specify the Printer settings as paper size, paper 
orientation, color or monochromatic, etc. => Print

Preview 1: versions 14 to 16: File => print preview => allows the visualization of the printing work
Preview 2: version 17 and up: File => Print => opens the Printing menu with preview and other options 
for scale, layers, etc.
The following screen is for the Windows versions

In the Mac Versions, the process is in two steps
By selecting File => Page Setup => you will see the screen below. Where you can select the page settings.

Notice that in this case, the scale that we see in this menu, is the printing scale => it is not 
related with the architectural scale in the file



By selecting File => Print => or File => Print to scale => you can choose additional options, include the 
settings related with your specific printer.

Converting the Punch plans to JPG, BMP or other raster format
Option 1: (Version 16 and older): Visualize your Punch Software (R) plan in the screen => set the zoom 
adequately to fit the plan in the screen => create a screenshot (press Print screen) => Go to your favorite 
graphic program => Paste => Crop the image => Save As => xxx.jpg or bmp or other format => these 
plans are not scaled.



Option 2: (Version 17 and up): File => Export => 2D Image => You can set the format, size, layers, and 
plan visibility => these plans are not scaled.

Question for this issue: Where can I find graphic programs?
Answer: In my Facebook page, you will find the names and websites for these programs

Exporting Punch floor plans to CAD 
First you must create a file for each floor of the project => each file must only have one level (1st floor, 
2nd floor, etc.) => Verify if all the required elements and tabs are visible in the screen => File =>
Export to => DXF / DWG (For legacy versions => Power Tools => DXF / DWG Exporter) => Select the 
version => Export)
You can print the plans, or open with a CAD program or send by email => these floor plans are scaled.

Convert Punch plans to PDF files
You can convert your Punch Software (R) floor plans to PDF documents. 
Windows versions: the first step: you need to get a PDF writer software. If you don’t have this program, 
browse the web with the keywords “free PDF” => you will find several free programs => check the 
compatibility between the software and your OS (XP, Win7, etc.) => download and install the program. 
Once the software is installed, the new program will create a virtual printer (as you can see in the images 
below).

https://www.facebook.com/punchhelpers.links


Open your Punch Software (R) program and your floor plan => proceed to print as indicated for a normal 
printing => the Print menu will open => select your virtual  printer (outlined in red in the images above). 

Usually, the PDF writers have different paper sizes (A3, A1, etc.) so, you can choose the right 
paper size to fit your drawing. You can also print to PDF the live view images, however, not all the PDF 
writers print the elevations
Mac versions: you can use the PDF tool embedded with your OS to print your PDF floor plans
Open your Punch Software (R) program and your floor plan => proceed to print as indicated in this step 
=> at the bottom – left of the screen => click on the PDF button (outlined in red in the image) => you can 
either open the PDF in Preview or Save as PDF



DWF files
The DWG files are created with some free applications developed by a CAD manufacturer.

Question for this issue: Where can I find a program to create DWF files?
Answer: In my Facebook page, you will find the names and websites for these programs

These files are accepted by commercial print shops and they work as PDF files. 

 More Information and Tutorials about importing objects can be found in Patricia’s e-books

Learning Punch Software (R): Importing, Exporting and Printing

Learning Punch Software (R): Basic & Advanced Training

10 QUESTIONS ANSWERED 

_________________________________________________________________________

Question 1: How do I return to the Quick Start screen?
Answer 1: You can’t. The Quick Start screen is like a napkin sketch, so after you click the Continue 
button, you are in the project screen, therefore, it is not possible to return to the sketch stage.

Question 2: My menus are deactivated, why is this happening?
Answer 2: because you are in the Quick Start stage. After you click the Continue button, you will be able 
to use all the Punch Software (R) features

Question 3: I am a Mac user. I can’t see the plants, objects, etc. Where are they?
Answer 3: Confirm if the Inspector is visible. Window menu => Show inspector

Question 4: I can’t change the default dimensions of my doors and windows. Is this a bug?
Answer 4: It is not a bug. After writing any new value in the elevation bar (top) or in the properties bar 
(right pane) or in the Inspector, like elevation, roof pitches, doors' or windows’ dimensions, etc. you need 
to press Enter in your keyboard so the change takes effect.

Question 5: I imported a picture of my house but I can’t change the siding color or apply any texture. 
What am I doing wrong?
Answer 5: the imported picture is just a 2D board and you can't modify the image after you imported it. 
You can add elements in front of it, but in live view, you can't modify the picture or make the picture a 

https://www.smashwords.com/books/view/343465
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3D object, change the colors of the picture, etc. In order to modify the colors of the picture, you can use 
the any image program before you import the picture in Punch Software (R).

Question 6: When I apply a texture or a color, it goes to the sky. When I try to render, I see a black 
screen. What can I do?
Answer 6: these are symptoms of a video card problem. Reduce the accelerations and change the color 
settings from 32 bit to 16 bit.

Question 7: How do I set a driveway to go down following a slope?
Answer 7: Create your driveways / sidewalks with several points (handles) => select the driveways / 
sidewalks => Edit (or right click) => Float Object Above Topography. You can visualize the solution in 
this image in my website.

Question 8: My screen seems cut off to the right of the "Tool Options" bar? Do you know how I can fix 
this?
Answer 8: Yes, it is a configuration issue. Search the configuration for the Display (The tab is different in 
different Windows / Video card configurations) => Set the DPI settings to Normal Size (96 DPI).

Question 9: How do I deactivate the Auto Roof feature?
Answer 9: Click on the exterior walls' perimeter => you will see the eave => when you select the roof 
eave, the screen looks like the image.
Go to the properties bar (right pane) => tool options => Options => uncheck "automatically generates 
panels" (outlined in red) 

http://www.punchhelpers.com/exterior10.html


Question 10: I added columns in the Framing tab, however I can’t see these elements in live view. How 
do I achieve this?
Answer 10: The structural elements like columns, beams, etc. developed with the tools available in the 
Framing tab will not appear in the live view screen / textured style. To see them open the live view screen 
using 3D => rendering style => Framing.

 More Information and Tutorials about any issue with Punch Software (R), check Patricia’s e-books

Learning Punch Software (R): Importing, Exporting and Printing

Learning Punch Software (R): Basic & Advanced Training

ABOUT ME AND MY BOOKS 

_________________________________________________________________________

About me: If you didn’t read my story in my e-books, here it is:
My name is Patricia Gamburgo. I became an Architect in December of 1980
I remember that, after my graduation, I felt that I didn’t have all the tools and answers for a design 
professional. So, I returned to University, for Post-Graduation Engineering courses. After this and during 
the following years, I worked with different companies, doing design and project management, as well as 
cost estimation and construction management (on site). 
Being the manager of a big project, supervising different professionals and coordinating all the documents 
turned out to be my biggest professional challenge.
Looking for tools and solutions, I went to College to learn “Advanced CAD applications”, where I was 
introduced to the concept of Building Information Modeling (BIM) and to the programs allowing the 
connection of all the documents of a project: I had found the answers I was looking for!
In 2001, due to a project deadline I bought my first Punch! Software (R) program: it was Professional 
Version 4. I completed my project in time, and the images were a success.
After this project, I spent many hours looking for answers, learning the program, understanding how the 
program thinks. I was so excited with the software that in 2002, I started my website 
http://www.punchhelpers.com , providing services and training using Punch! Software (R).
In the past few years, I received dozens of emails from customers, forum users and trainees asking for 
books. They requested some type of book that could be easily searched and showing how the program 
thinks in an architectural environment.
So, I decided to write a series of e-books, combining my experience with Punch! Software (R) with my 
professional knowledge as Architect.

http://www.punchhelpers.com/
https://www.smashwords.com/books/view/343465
http://www.smashwords.com/books/view/298949


My e-books: they contain all the necessary elements to learn and master the Punch! Software (R) 
programs. The information can be used and accessed in different ways. 

- Following the entire e-book provides a complete training to learn the Punch! Software (R) programs, not 
only by following tutorials and guides, but understanding how the program thinks. 
- The tutorials show the “How To” for specific uses: How to start a project? How to insert a picture and 
landscape it? , How to create a walk-out basement?  How to slope a lot? Just to name a few. 
- The Visual Guides are graphic solutions that allow the visualization of the tools’ concepts. 
- Questions and answers by topic and general issues, that reflect the most asked and answered posts at the 
Punch! Software (R) Community Forum
- Topics and tools are linked on the screen, so, while you are consulting an item, you can easily access the 
additional information. 
- You can search the information by content, by topic or by keyword
- The constructive elements include the necessary technical information. For example: the roof chapter 
includes a glossary explaining the names of the different parts of a roof as well as the name and 
development of 21 different types of roofs. Or, if you wish to develop a staircase, for example, you will 
find not only how to create it using Punch! Software (R), but also, how stairs are calculated in real life.
- The e-books contains hundreds of color images, covering all the Punch versions, including Version 17.5.

Do you want to know more? Check this free video presentation

Or, just click on this link

Where can I buy the e-books? 

http://youtu.be/QgK_DzIHfss
http://youtu.be/QgK_DzIHfss


They are available in all the e-book stores or you can follow these links

Learning Punch Software (R): Importing, Exporting and Printing

Learning Punch Software (R): Basic & Advanced Training

Thank you!

Patricia Gamburgo
October 18, 2013
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